Jump to content


Photo

Polycom Volume reset to default


  • Please log in to reply
11 replies to this topic

#1 nas

nas

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 24 August 2008 - 08:23 AM

After reading Polycom admin guide I learn that you can manage the volume by changing master config persist value from 0 to 1. Since this master config are being created/saved somewhere within pbx that can't be found "provisioning/polycom_sip_0004F21AFF50.cfg” editing master config within each MAC address of phone gets over written when pbx/phone restarts.

We were told by PBXnsip guys that this is hardcoded somewhere in source file so I tried to take 2nd route by creating full set of polycom apps/config/bootrom files then upload them to "pbx/tftp" still no luck.

All it would have taken PBXNSIP guys to either provide access to whereever this config is managed “provisioning/polycom_sip_0004F21AFF50.cfg” so we can make changes or they should change the settings to default from

voice.volume.persist.handset="0" voice.volume.persist.headset="0" voice.volume.persist.handsfree="1"/>

to

voice.volume.persist.handset="1" voice.volume.persist.headset="1" voice.volume.persist.handsfree="1"/>

It is certainly the worst practice, where such feature like how users control volume and any other settings that would make some people life hell by requiring settings to be reset every time in my case a call volume for every single call!
The default volume level by polycom is absolutely useless; you can’t hear anything what other party is saying unless you increase the volume to max. It has made my client life hell especially when their environment is not that quite.
It’s PBXnsip or Polycom but this issue should have been addressed a while back.

Beside the other issues I has to gone through for past 2 weeks with this! Now in order to changed this value from 0 to 1 it took me over 16 hours of my personal time by trying everything else then I am told to post it here...

FYI: the login info to my pbx box is mailed

#2 Vodia PBX

Vodia PBX

    Advanced Member

  • Administrators
  • PipPipPip
  • 8,076 posts
  • Gender:Male

Posted 24 August 2008 - 02:46 PM

After reading Polycom admin guide I learn that you can manage the volume by changing master config persist value from 0 to 1. Since this master config are being created/saved somewhere within pbx that can't be found "provisioning/polycom_sip_0004F21AFF50.cfg" editing master config within each MAC address of phone gets over written when pbx/phone restarts.

We were told by PBXnsip guys that this is hardcoded somewhere in source file so I tried to take 2nd route by creating full set of polycom apps/config/bootrom files then upload them to "pbx/tftp" still no luck.


You can place the template into the html directory (not the tftp directory), and then you can change the value in the template. Attached is the latest template (please note that once you put it into the html directory, you will miss new versions of the template that come with new PBX versions).

All it would have taken PBXNSIP guys to either provide access to whereever this config is managed "provisioning/polycom_sip_0004F21AFF50.cfg" so we can make changes or they should change the settings to default from

voice.volume.persist.handset="0" voice.volume.persist.headset="0" voice.volume.persist.handsfree="1"/>

to

voice.volume.persist.handset="1" voice.volume.persist.headset="1" voice.volume.persist.handsfree="1"/>

It is certainly the worst practice, where such feature like how users control volume and any other settings that would make some people life hell by requiring settings to be reset every time in my case a call volume for every single call!

The default volume level by polycom is absolutely useless; you can't hear anything what other party is saying unless you increase the volume to max. It has made my client life hell especially when their environment is not that quite.

It's PBXnsip or Polycom but this issue should have been addressed a while back.


Do you think it makes sense to make this parameter configurable? We did not really think about this parameter, we just took the default coming from Polycom. This is usually a reasonable approach.

There are a lot of configurable parameters (well, the file is 120 KB!!!), so we definitevely don't want to include all of them. For example, we included a parameter that makes it possible to turn the HTTP server off (security leak).

Also, if you are using a analog gateway (FXO) you might have to check the gain on the gateway (see http://wiki.pbxnsip....Gain_Adjustment). Maybe the gain there is too low and then you have to increase the volume on the phones to hear something. The default config on the Polycoms is usually pretty good if the incoming gain is okay.

Beside the other issues I has to gone through for past 2 weeks with this! Now in order to changed this value from 0 to 1 it took me over 16 hours of my personal time by trying everything else then I am told to post it here...


Ouch. At least we want to avoid that other guys go through the same pain again.

Attached Files



#3 nas

nas

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 25 August 2008 - 08:01 AM

You can place the template into the html directory (not the tftp directory), and then you can change the value in the template. Attached is the latest template (please note that once you put it into the html directory, you will miss new versions of the template that come with new PBX versions).


I will follow what you suggested but just one quick question about your point above. What's the different between this template versions and why can't we use the one that can be used with new pbx versions?

Thanks

#4 Vodia PBX

Vodia PBX

    Advanced Member

  • Administrators
  • PipPipPip
  • 8,076 posts
  • Gender:Male

Posted 25 August 2008 - 01:43 PM

I will follow what you suggested but just one quick question about your point above. What's the different between this template versions and why can't we use the one that can be used with new pbx versions?


It is an upgrade problem. When you perform an upgrade of the PBX and we update the template on the pbxnsip side, you will not get those updates unless you remove the file from the file system. May not be a major problem, just want to mention it.

#5 sudo

sudo

    Advanced Member

  • Members
  • PipPipPip
  • 214 posts

Posted 03 July 2013 - 12:22 PM

Im having a similar issue. My Polcom IP331 will not keep the set incall valume. It keeps going back to the default setting after every call.

 

The polycom_sip.cfg file has the following parameter set:

 

<volume voice.volume.persist.handset="1" voice.volume.persist.headset="1" voice.volume.persist.handsfree="1"/>

 

This was the default. In all my research on Polycom forums, it states that this enables the volume to persist.

 

However my incall volume is not persisting. As stated before it goes back to the defualt value after every call.



#6 Vodia PBX

Vodia PBX

    Advanced Member

  • Administrators
  • PipPipPip
  • 8,076 posts
  • Gender:Male

Posted 03 July 2013 - 07:31 PM

We had that in the old times (pbxnsip) as a provisioning parameter. Polycom has the default to restore the volume--I guess that makes sense because the volume differs significantly depending on who is calling (device) and who is talking. Also it helps to keep the system in a kind of calibrated state. But of course you can change the polycom provisioning template and change the setting.



#7 sudo

sudo

    Advanced Member

  • Members
  • PipPipPip
  • 214 posts

Posted 05 July 2013 - 10:43 AM

We had that in the old times (pbxnsip) as a provisioning parameter. Polycom has the default to restore the volume--I guess that makes sense because the volume differs significantly depending on who is calling (device) and who is talking. Also it helps to keep the system in a kind of calibrated state. But of course you can change the polycom provisioning template and change the setting.

Im not seeing the parameter "<volume voice.volume.persist.handset="1..." in the polycom_master.xml or polycom_all.xml

 

Am in in the wrong file? Is it a different string than the one above?

 

Thanks

Sudo



#8 Vodia PBX

Vodia PBX

    Advanced Member

  • Administrators
  • PipPipPip
  • 8,076 posts
  • Gender:Male

Posted 05 July 2013 - 10:54 AM

You will have to add this by yourself... The new snom ONE Polycom templates contains only the things that should be different from the defaults. 



#9 sudo

sudo

    Advanced Member

  • Members
  • PipPipPip
  • 214 posts

Posted 08 July 2013 - 10:44 AM

You will have to add this by yourself... The new snom ONE Polycom templates contains only the things that should be different from the defaults. 

Well the defaults in the .cfg file is set to have this persist :wacko:. So adding the stanza should result in the same .cfg as it is now. And it currently not perisiting.



#10 JTEL

JTEL

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts

Posted 08 July 2013 - 02:54 PM

I can share with you a file that works, and that i use, and it has the volume setting fixed as well as BLF on the screen. However, i need to know if you use srv records to register phones or regular A record.

 

PM me.

 

Thanks,



#11 sudo

sudo

    Advanced Member

  • Members
  • PipPipPip
  • 214 posts

Posted 09 July 2013 - 05:31 PM

Thanks JTEL,

 

I appended the below stanza to the end of polycom_all.xml:

 

voice.volume.persist.handset="1"
voice.volume.persist.headset="1"
voice.volume.persist.handsfree="1"
 
Works now.


#12 Vodia PBX

Vodia PBX

    Advanced Member

  • Administrators
  • PipPipPip
  • 8,076 posts
  • Gender:Male

Posted 09 July 2013 - 07:43 PM

Maybe we should vote  :rolleyes:






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users